What’s Vulnerable › Vulnerabilities
CVE-2017-5511
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-24 · updated 2026-06-17
- Weakness: CWE-119
Description
coders/psd.c in ImageMagick allows remote attackers to have unspecified impact by leveraging an improper cast, which triggers a heap-based buffer overflow.
Affected products
- Debian Linux: 8.0, 9.0
- ImageMagick: before 6.9.7-3; from 7.0.0-0 before 7.0.4-3 — fixed in 6.9.7-3, 7.0.4-3
How to fix
Upgrade to a fixed version: ImageMagick 6.9.7-3, 7.0.4-3. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95746
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851374
- https://github.com/ImageMagick/ImageMagick/commit/7d65a814ac76bd04760072c33e452371692ee790
- https://github.com/ImageMagick/ImageMagick/commit/c8c6a0f123d5e35c173125365c97e2c0fc7eca42
- https://github.com/ImageMagick/ImageMagick/issues/347
- https://security.gentoo.org/glsa/201702-09
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
Get alerted when CVE-2017-5511 or the next vulnerability affects your stack