What’s Vulnerable › Vulnerabilities

CVE-2017-5638: Apache Struts Remote Code Execution Vulnerability

Description

The Jakarta Multipart parser in Apache Struts 2 2.3.x before 2.3.32 and 2.5.x before 2.5.10.1 has incorrect exception handling and error-message generation during file-upload attempts, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

Affected products

How to fix

Upgrade to a fixed version: Apache Struts 2.3.32, 2.5.10.1; Aruba ClearPass Policy Manager 6.6.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-5638 or the next vulnerability affects your stack