What’s Vulnerable › Vulnerabilities
CVE-2017-5847
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-09 · updated 2026-06-17
- Weakness: CWE-125
Description
The gst_asf_demux_process_ext_content_desc function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving extended content descriptors.
Affected products
- Debian Linux: 8.0, 9.0
- GStreamer: before 1.11.2 — fixed in 1.11.2
How to fix
Upgrade to a fixed version: GStreamer 1.11.2. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3821
- http://www.openwall.com/lists/oss-security/2017/02/01/7
- http://www.openwall.com/lists/oss-security/2017/02/02/9
- http://www.securityfocus.com/bid/96001
- https://bugzilla.gnome.org/show_bug.cgi?id=777955#c3
- https://github.com/GStreamer/gst-plugins-ugly/commit/d21017b52a585f145e8d62781bcc1c5fefc7ee37
- https://lists.debian.org/debian-lts-announce/2020/05/msg00030.html
- https://security.gentoo.org/glsa/201705-10
- http://www.debian.org/security/2017/dsa-3821
- http://www.openwall.com/lists/oss-security/2017/02/01/7
- http://www.openwall.com/lists/oss-security/2017/02/02/9
- http://www.securityfocus.com/bid/96001
Get alerted when CVE-2017-5847 or the next vulnerability affects your stack