What’s Vulnerable › Vulnerabilities
CVE-2017-5848
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-09 · updated 2026-06-17
- Weakness: CWE-125
Description
The gst_ps_demux_parse_psm function in gst/mpegdemux/gstmpegdemux.c in gst-plugins-bad in GStreamer allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors involving PSM parsing.
Affected products
- Debian Linux: 8.0, 9.0
- GStreamer: before 1.11.2 — fixed in 1.11.2
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: GStreamer 1.11.2. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3818
- http://www.openwall.com/lists/oss-security/2017/02/01/7
- http://www.openwall.com/lists/oss-security/2017/02/02/9
- http://www.securityfocus.com/bid/96001
- https://access.redhat.com/errata/RHSA-2017:2060
- https://bugzilla.gnome.org/show_bug.cgi?id=777957#c3
- https://lists.debian.org/debian-lts-announce/2020/03/msg00038.html
- https://security.gentoo.org/glsa/201705-10
- http://www.debian.org/security/2017/dsa-3818
- http://www.openwall.com/lists/oss-security/2017/02/01/7
- http://www.openwall.com/lists/oss-security/2017/02/02/9
- http://www.securityfocus.com/bid/96001
Get alerted when CVE-2017-5848 or the next vulnerability affects your stack