What’s Vulnerable › Vulnerabilities
CVE-2017-5930
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-20 · updated 2026-06-17
- Weakness: CWE-862
Description
The AliasHandler component in PostfixAdmin before 3.0.2 allows remote authenticated domain admins to delete protected aliases via the delete parameter to delete.php, involving a missing permission check.
Affected products
- openSUSE Leap: 42.1, 42.2
- Postfixadmin Project Postfixadmin: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: Postfixadmin Project Postfixadmin 3.0.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2017-02/msg00076.html
- http://www.openwall.com/lists/oss-security/2017/02/08/1
- http://www.openwall.com/lists/oss-security/2017/02/09/1
- http://www.securityfocus.com/bid/96142
- https://github.com/postfixadmin/postfixadmin/blob/postfixadmin-3.0.2/CHANGELOG.TXT
- https://github.com/postfixadmin/postfixadmin/pull/23
- https://sourceforge.net/p/postfixadmin/mailman/message/35646827/
- http://lists.opensuse.org/opensuse-updates/2017-02/msg00076.html
- http://www.openwall.com/lists/oss-security/2017/02/08/1
- http://www.openwall.com/lists/oss-security/2017/02/09/1
- http://www.securityfocus.com/bid/96142
- https://github.com/postfixadmin/postfixadmin/blob/postfixadmin-3.0.2/CHANGELOG.TXT
Get alerted when CVE-2017-5930 or the next vulnerability affects your stack