What’s Vulnerable › Vulnerabilities
CVE-2017-5934
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the link dialogue in GUI editor in MoinMoin before 1.9.10 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Moinmoin: before 1.9.10 — fixed in 1.9.10
- openSUSE Leap: 15.0, 42.3
How to fix
Upgrade to a fixed version: Moinmoin 1.9.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2018-10/msg00024.html
- http://moinmo.in/SecurityFixes
- https://github.com/moinwiki/moin-1.9/commit/70955a8eae091cc88fd9a6e510177e70289ec024
- https://lists.debian.org/debian-lts-announce/2018/10/msg00007.html
- https://usn.ubuntu.com/3794-1/
- https://www.debian.org/security/2018/dsa-4318
- http://lists.opensuse.org/opensuse-security-announce/2018-10/msg00024.html
- http://moinmo.in/SecurityFixes
- https://github.com/moinwiki/moin-1.9/commit/70955a8eae091cc88fd9a6e510177e70289ec024
- https://lists.debian.org/debian-lts-announce/2018/10/msg00007.html
- https://usn.ubuntu.com/3794-1/
- https://www.debian.org/security/2018/dsa-4318
Get alerted when CVE-2017-5934 or the next vulnerability affects your stack