What’s Vulnerable › Vulnerabilities
CVE-2017-5946
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-27 · updated 2026-06-17
- Weakness: CWE-22
Description
The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses "../" pathname substrings to write arbitrary files to the filesystem.
Affected products
- Debian Linux: 8.0, 9.0
- Rubyzip Project Rubyzip: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Rubyzip Project Rubyzip 1.2.1. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3801
- http://www.securityfocus.com/bid/96445
- https://github.com/rubyzip/rubyzip/issues/315
- https://github.com/rubyzip/rubyzip/releases
- http://www.debian.org/security/2017/dsa-3801
- http://www.securityfocus.com/bid/96445
- https://github.com/rubyzip/rubyzip/issues/315
- https://github.com/rubyzip/rubyzip/releases
Get alerted when CVE-2017-5946 or the next vulnerability affects your stack