What’s Vulnerable › Vulnerabilities
CVE-2017-6188
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
Affected products
- Debian Linux: 8.0
- Munin-Monitoring Munin: before 2.0.30.1; from 2.1.0 before 2.999.9 — fixed in 2.0.30.1, 2.999.9
How to fix
Upgrade to a fixed version: Munin-Monitoring Munin 2.0.30.1, 2.999.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96399
- https://bugs.debian.org/855705
- https://github.com/munin-monitoring/munin/issues/721
- https://security.gentoo.org/glsa/201710-05
- https://www.debian.org/security/2017/dsa-3794
- http://www.securityfocus.com/bid/96399
- https://bugs.debian.org/855705
- https://github.com/munin-monitoring/munin/issues/721
- https://security.gentoo.org/glsa/201710-05
- https://www.debian.org/security/2017/dsa-3794
Get alerted when CVE-2017-6188 or the next vulnerability affects your stack