What’s Vulnerable › Vulnerabilities
CVE-2017-6198
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-06 · updated 2026-06-17
- Weakness: CWE-400
Description
The Supervisor in Sandstorm doesn't set and enforce the resource limits of a process. This allows remote attackers to cause a denial of service by launching a fork bomb in the sandbox, or by using a large amount of disk space.
Affected products
- Sandstorm: before 0.203 — fixed in 0.203
How to fix
Upgrade to a fixed version: Sandstorm 0.203. Check the vendor advisory for mitigations.
References
- https://devco.re/blog/2018/01/26/Sandstorm-Security-Review-CVE-2017-6200-en/
- https://github.com/sandstorm-io/sandstorm/blob/v0.202/src/sandstorm/supervisor.c++#L824
- https://devco.re/blog/2018/01/26/Sandstorm-Security-Review-CVE-2017-6200-en/
- https://github.com/sandstorm-io/sandstorm/blob/v0.202/src/sandstorm/supervisor.c++#L824
Get alerted when CVE-2017-6198 or the next vulnerability affects your stack