What’s Vulnerable › Vulnerabilities
CVE-2017-6199
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-06 · updated 2026-06-17
- Weakness: CWE-287
Description
A remote attacker could bypass the Sandstorm organization restriction before build 0.203 via a comma in an email-address field.
Affected products
- Sandstorm: before 0.203 — fixed in 0.203
How to fix
Upgrade to a fixed version: Sandstorm 0.203. Check the vendor advisory for mitigations.
References
- https://devco.re/blog/2018/01/26/Sandstorm-Security-Review-CVE-2017-6200-en/
- https://github.com/sandstorm-io/sandstorm/blob/v0.202/shell/packages/sandstorm-db/db.js#L1112
- https://github.com/sandstorm-io/sandstorm/commit/37bd9a7f4eb776cdc2d3615f0bfea1254b66f59d
- https://sandstorm.io/news/2017-03-02-security-review
- https://devco.re/blog/2018/01/26/Sandstorm-Security-Review-CVE-2017-6200-en/
- https://github.com/sandstorm-io/sandstorm/blob/v0.202/shell/packages/sandstorm-db/db.js#L1112
- https://github.com/sandstorm-io/sandstorm/commit/37bd9a7f4eb776cdc2d3615f0bfea1254b66f59d
- https://sandstorm.io/news/2017-03-02-security-review
Get alerted when CVE-2017-6199 or the next vulnerability affects your stack