What’s Vulnerable › Vulnerabilities

CVE-2017-6369

Description

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

Affected products

How to fix

Upgrade to a fixed version: FirebirdSQL firebird 2.5.7, 3.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-6369 or the next vulnerability affects your stack