What’s Vulnerable › Vulnerabilities
CVE-2017-6414
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-15 · updated 2026-06-17
- Weakness: CWE-772
Description
Memory leak in the vcard_apdu_new function in card_7816.c in libcacard before 2.5.3 allows local guest OS users to cause a denial of service (host memory consumption) via vectors related to allocating a new APDU object.
Affected products
- Libcacard Project Libcacard: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Libcacard Project Libcacard 2.5.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/03/01/11
- http://www.securityfocus.com/bid/96541
- https://access.redhat.com/errata/RHSA-2017:2408
- https://bugzilla.redhat.com/show_bug.cgi?id=1427833
- https://cgit.freedesktop.org/spice/libcacard/commit/?id=9113dc6a303604a2d9812ac70c17d076ef11886c
- https://cgit.freedesktop.org/spice/libcacard/tree/NEWS?id=aaa5251791bf0b1640afcba77a7d79ea23c42d53
- http://www.openwall.com/lists/oss-security/2017/03/01/11
- http://www.securityfocus.com/bid/96541
- https://access.redhat.com/errata/RHSA-2017:2408
- https://bugzilla.redhat.com/show_bug.cgi?id=1427833
- https://cgit.freedesktop.org/spice/libcacard/commit/?id=9113dc6a303604a2d9812ac70c17d076ef11886c
- https://cgit.freedesktop.org/spice/libcacard/tree/NEWS?id=aaa5251791bf0b1640afcba77a7d79ea23c42d53
Get alerted when CVE-2017-6414 or the next vulnerability affects your stack