What’s Vulnerable › Vulnerabilities
CVE-2017-6797
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in bug_change_status_page.php in MantisBT before 1.3.7 and 2.x before 2.2.1 allows remote attackers to inject arbitrary JavaScript via the 'action_type' parameter.
Affected products
- mantisbt: before 1.3.7; from 2.0.0 before 2.2.1 — fixed in 1.3.7, 2.2.1
How to fix
Upgrade to a fixed version: mantisbt 1.3.7, 2.2.1. Check the vendor advisory for mitigations.
References
- http://www.mantisbt.org/bugs/view.php?id=22486
- http://www.openwall.com/lists/oss-security/2017/03/10/1
- http://www.securityfocus.com/bid/96818
- http://www.securitytracker.com/id/1037978
- https://github.com/mantisbt/mantisbt/commit/a2d90ecabf3bcf3aa22ed9dbbecfd3d37902956f
- https://github.com/mantisbt/mantisbt/commit/c272c3f65da9677e505ff692b1f1e476b3afa56e
- http://www.mantisbt.org/bugs/view.php?id=22486
- http://www.openwall.com/lists/oss-security/2017/03/10/1
- http://www.securityfocus.com/bid/96818
- http://www.securitytracker.com/id/1037978
- https://github.com/mantisbt/mantisbt/commit/a2d90ecabf3bcf3aa22ed9dbbecfd3d37902956f
- https://github.com/mantisbt/mantisbt/commit/c272c3f65da9677e505ff692b1f1e476b3afa56e
Get alerted when CVE-2017-6797 or the next vulnerability affects your stack