What’s Vulnerable › Vulnerabilities

CVE-2017-6910

Description

The HTTP and WebSocket engine components in the server in Kaazing Gateway before 4.5.3 hotfix-1, Gateway - JMS Edition before 4.0.5 hotfix-15, 4.0.6 before hotfix-4, 4.0.7, 4.0.9 before hotfix-19, 4.4.x before 4.4.2 hotfix-1, 4.5.x before 4.5.3 hotfix-1, and Gateway Community and Enterprise Editions before 5.6.0 allow remote attackers to bypass intended access restrictions and obtain sensitive information via vectors related to HTTP request handling.

Affected products

How to fix

Upgrade to a fixed version: Kaazing Gateway 4.4.2, 4.5.3; Tenefit Kaazing Websocket Gateway 5.6.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-6910 or the next vulnerability affects your stack