What’s Vulnerable › Vulnerabilities
CVE-2017-6927
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Drupal: from 7.0 before 7.57; from 8.4.0 before 8.4.5 — fixed in 7.57, 8.4.5
How to fix
Upgrade to a fixed version: Drupal 7.57, 8.4.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103138
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001
- http://www.securityfocus.com/bid/103138
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001
Get alerted when CVE-2017-6927 or the next vulnerability affects your stack