What’s Vulnerable › Vulnerabilities
CVE-2017-6928
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-732
Description
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Drupal: from 7.0 before 7.57 — fixed in 7.57
How to fix
Upgrade to a fixed version: Drupal 7.57. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001
Get alerted when CVE-2017-6928 or the next vulnerability affects your stack