What’s Vulnerable › Vulnerabilities
CVE-2017-6930
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-01 · updated 2026-06-17
Description
In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().
Affected products
- Drupal: from 8.4.0 before 8.4.5 — fixed in 8.4.5
How to fix
Upgrade to a fixed version: Drupal 8.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-6930 or the next vulnerability affects your stack