What’s Vulnerable › Vulnerabilities
CVE-2017-6931
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-434
Description
In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.
Affected products
- Drupal: from 8.4.0 before 8.4.5 — fixed in 8.4.5
How to fix
Upgrade to a fixed version: Drupal 8.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-6931 or the next vulnerability affects your stack