What’s Vulnerable › Vulnerabilities
CVE-2017-6932
- Severity: medium (CVSS 4.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-01 · updated 2026-06-17
- Weakness: CWE-601
Description
Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Drupal: from 7.0 before 7.57 — fixed in 7.57
How to fix
Upgrade to a fixed version: Drupal 7.57. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001
Get alerted when CVE-2017-6932 or the next vulnerability affects your stack