What’s Vulnerable › Vulnerabilities
CVE-2017-7161
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-03 · updated 2026-06-17
- Weakness: CWE-77
Description
An issue was discovered in certain Apple products. Safari before 11.0.2 is affected. The issue involves the "WebKit Web Inspector" component. It allows remote attackers to execute arbitrary code via special characters that trigger command injection.
Affected products
- Apple Safari: before 11.0.2 — fixed in 11.0.2
- Canonical Ubuntu Linux: 16.04, 17.10
How to fix
Upgrade to a fixed version: Apple Safari 11.0.2. Check the vendor advisory for mitigations.
References
- https://support.apple.com/HT208324
- https://usn.ubuntu.com/3551-1/
- https://support.apple.com/HT208324
- https://usn.ubuntu.com/3551-1/
Get alerted when CVE-2017-7161 or the next vulnerability affects your stack