What’s Vulnerable › Vulnerabilities
CVE-2017-7167
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-03 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in certain Apple products. Xcode before 9.2 is affected. The issue involves the "ld64" component. A buffer overflow allows remote attackers to execute arbitrary code via crafted source code.
Affected products
- Apple Xcode: before 9.2 — fixed in 9.2
How to fix
Upgrade to a fixed version: Apple Xcode 9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-7167 or the next vulnerability affects your stack