What’s Vulnerable › Vulnerabilities
CVE-2017-7178
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-03-18 · updated 2026-06-17
- Weakness: CWE-352
Description
CSRF was discovered in the web UI in Deluge before 1.3.14. The exploitation methodology involves (1) hosting a crafted plugin that executes an arbitrary program from its __init__.py file and (2) causing the victim to download, install, and enable this plugin.
Affected products
- Debian Linux: 8.0
- Dev Deluge: before 1.3.14 — fixed in 1.3.14
How to fix
Upgrade to a fixed version: Dev Deluge 1.3.14. Check the vendor advisory for mitigations.
References
- http://dev.deluge-torrent.org/wiki/ReleaseNotes/1.3.14
- http://git.deluge-torrent.org/deluge/commit/?h=1.3-stable&id=318ab179865e0707d7945edc3a13a464a108d583
- http://git.deluge-torrent.org/deluge/commit/?h=develop&id=11e8957deaf0c76fdfbac62d99c8b6c61cfdddf9
- http://seclists.org/fulldisclosure/2017/Mar/6
- http://www.debian.org/security/2017/dsa-3856
- http://www.securityfocus.com/bid/97041
- https://bugs.debian.org/857903
- https://security.gentoo.org/glsa/201703-06
- http://dev.deluge-torrent.org/wiki/ReleaseNotes/1.3.14
- http://git.deluge-torrent.org/deluge/commit/?h=1.3-stable&id=318ab179865e0707d7945edc3a13a464a108d583
- http://git.deluge-torrent.org/deluge/commit/?h=develop&id=11e8957deaf0c76fdfbac62d99c8b6c61cfdddf9
- http://seclists.org/fulldisclosure/2017/Mar/6
Get alerted when CVE-2017-7178 or the next vulnerability affects your stack