What’s Vulnerable › Vulnerabilities

CVE-2017-7187

Description

The sg_ioctl function in drivers/scsi/sg.c in the Linux kernel through 4.10.4 allows local users to cause a denial of service (stack-based buffer overflow) or possibly have unspecified other impact via a large command size in an SG_NEXT_CMD_LEN ioctl call, leading to out-of-bounds write access in the sg_write function.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.18.50, 4.1.40, 4.10.9, 4.4.60. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7187 or the next vulnerability affects your stack