What’s Vulnerable › Vulnerabilities
CVE-2017-7235
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-23 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Affected products
- Cloudflare-Scrape Project Cloudflare-Scrape: 1.6.6, 1.6.7, 1.6.8, 1.7.0, 1.7.1
References
- http://www.securityfocus.com/bid/97191
- https://github.com/Anorov/cloudflare-scrape/issues/97
- https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0
- http://www.securityfocus.com/bid/97191
- https://github.com/Anorov/cloudflare-scrape/issues/97
- https://github.com/Anorov/cloudflare-scrape/releases/tag/1.8.0
Get alerted when CVE-2017-7235 or the next vulnerability affects your stack