What’s Vulnerable › Vulnerabilities

CVE-2017-7294

Description

The vmw_surface_define_ioctl function in drivers/gpu/drm/vmwgfx/vmwgfx_surface.c in the Linux kernel through 4.10.6 does not validate addition of certain levels data, which allows local users to trigger an integer overflow and out-of-bounds write, and cause a denial of service (system hang or crash) or possibly gain privileges, via a crafted ioctl call for a /dev/dri/renderD* device.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.107, 3.12.74, 3.16.44, 3.18.50. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7294 or the next vulnerability affects your stack