What’s Vulnerable › Vulnerabilities

CVE-2017-7308

Description

The packet_set_ring function in net/packet/af_packet.c in the Linux kernel through 4.10.6 does not properly validate certain block-size data, which allows local users to cause a denial of service (integer signedness error and out-of-bounds write), or gain privileges (if the CAP_NET_RAW capability is held), via crafted system calls.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.107, 3.12.74, 3.16.44, 3.18.52. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7308 or the next vulnerability affects your stack