What’s Vulnerable › Vulnerabilities
CVE-2017-7466
- Severity: high (CVSS 8.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Affected products
- Red Hat Ansible: before 2.3 — fixed in 2.3
- OpenStack: 10, 11
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/97595
- https://access.redhat.com/errata/RHSA-2017:1244
- https://access.redhat.com/errata/RHSA-2017:1334
- https://access.redhat.com/errata/RHSA-2017:1476
- https://access.redhat.com/errata/RHSA-2017:1499
- https://access.redhat.com/errata/RHSA-2017:1599
- https://access.redhat.com/errata/RHSA-2017:1685
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7466
- http://www.securityfocus.com/bid/97595
- https://access.redhat.com/errata/RHSA-2017:1244
- https://access.redhat.com/errata/RHSA-2017:1334
- https://access.redhat.com/errata/RHSA-2017:1476
Get alerted when CVE-2017-7466 or the next vulnerability affects your stack