What’s Vulnerable › Vulnerabilities
CVE-2017-7467
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-11 · updated 2026-06-17
- Weakness: CWE-787
Description
A buffer overflow flaw was found in the way minicom before version 2.7.1 handled VT100 escape sequences. A malicious terminal device could potentially use this flaw to crash minicom, or execute arbitrary code in the context of the minicom process.
Affected products
- [UNKNOWN] minicom: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: [UNKNOWN] minicom 2.7.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/04/18/5
- http://www.securityfocus.com/bid/97966
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7467
- https://security.gentoo.org/glsa/201706-13
- http://www.openwall.com/lists/oss-security/2017/04/18/5
- http://www.securityfocus.com/bid/97966
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7467
- https://security.gentoo.org/glsa/201706-13
Get alerted when CVE-2017-7467 or the next vulnerability affects your stack