What’s Vulnerable › Vulnerabilities
CVE-2017-7478
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-05-15 · updated 2026-06-17
- Weakness: CWE-617
Description
OpenVPN version 2.3.12 and newer is vulnerable to unauthenticated Denial of Service of server via received large control packet. Note that this issue is fixed in 2.3.15 and 2.4.2.
Affected products
- OpenVPN: 2.3.12, 2.3.13, 2.3.14, 2.4.0, 2.4.0-alpha2, 2.4.0-beta1 (+4)
References
- http://www.securityfocus.com/bid/98444
- http://www.securitytracker.com/id/1038473
- https://community.openvpn.net/openvpn/wiki/QuarkslabAndCryptographyEngineerAudits
- https://www.exploit-db.com/exploits/41993/
- http://www.securityfocus.com/bid/98444
- http://www.securitytracker.com/id/1038473
- https://community.openvpn.net/openvpn/wiki/QuarkslabAndCryptographyEngineerAudits
- https://www.exploit-db.com/exploits/41993/
Get alerted when CVE-2017-7478 or the next vulnerability affects your stack