What’s Vulnerable › Vulnerabilities

CVE-2017-7494: Samba Remote Code Execution Vulnerability

Description

Samba since version 3.5.0 and before 4.6.4, 4.5.10 and 4.4.14 is vulnerable to remote code execution vulnerability, allowing a malicious client to upload a shared library to a writable share, and then cause the server to load and execute it.

Affected products

How to fix

Upgrade to a fixed version: Samba 4.4.0, 4.4.14, 4.5.10, 4.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7494 or the next vulnerability affects your stack