What’s Vulnerable › Vulnerabilities
CVE-2017-7501
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-22 · updated 2026-06-17
- Weakness: CWE-59
Description
It was found that versions of rpm before 4.13.0.2 use temporary files with predictable names when installing an RPM. An attacker with ability to write in a directory where files will be installed could create symbolic links to an arbitrary location and modify content, and possibly permissions to arbitrary files, which could be used for denial of service or possibly privilege escalation.
Affected products
- RPM: before 4.13.0.3 — fixed in 4.13.0.3
How to fix
Upgrade to a fixed version: RPM 4.13.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/rpm-software-management/rpm/commit/404ef011c300207cdb1e531670384564aae04bdc
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://security.gentoo.org/glsa/201811-22
- https://github.com/rpm-software-management/rpm/commit/404ef011c300207cdb1e531670384564aae04bdc
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://security.gentoo.org/glsa/201811-22
Get alerted when CVE-2017-7501 or the next vulnerability affects your stack