What’s Vulnerable › Vulnerabilities
CVE-2017-7509
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-26 · updated 2026-06-17
- Weakness: CWE-20
Description
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
Affected products
- Red Hat Certificate System: before 8.1.20-1 — fixed in 8.1.20-1
How to fix
Upgrade to a fixed version: Red Hat Certificate System 8.1.20-1. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1039248
- https://access.redhat.com/errata/RHSA-2017:2560
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7509
- http://www.securitytracker.com/id/1039248
- https://access.redhat.com/errata/RHSA-2017:2560
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7509
Get alerted when CVE-2017-7509 or the next vulnerability affects your stack