What’s Vulnerable › Vulnerabilities
CVE-2017-7514
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-30 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) flaw was found in how the failed action entry is processed in Red Hat Satellite before version 5.8.0. A user able to specify a failed action could exploit this flaw to perform XSS attacks against other Satellite users.
Affected products
- Red Hat Satellite 6: before 5.8.0 — fixed in 5.8.0
How to fix
Upgrade to a fixed version: Red Hat Satellite 6 5.8.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:1558
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7514
- https://access.redhat.com/errata/RHSA-2017:1558
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7514
Get alerted when CVE-2017-7514 or the next vulnerability affects your stack