What’s Vulnerable › Vulnerabilities
CVE-2017-7526
- Severity: medium (CVSS 6.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-26 · updated 2026-06-17
- Weakness: CWE-200
Description
libgcrypt before version 1.7.8 is vulnerable to a cache side-channel attack resulting into a complete break of RSA-1024 while using the left-to-right method for computing the sliding-window expansion. The same attack is believed to work on RSA-2048 with moderately more computation. This side-channel requires that attacker can run arbitrary software on the hardware where the private RSA key is used.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0, 9.0
- gnupg Libgcrypt: before 1.7.8 — fixed in 1.7.8
How to fix
Upgrade to a fixed version: gnupg Libgcrypt 1.7.8. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/99338
- http://www.securitytracker.com/id/1038915
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7526
- https://eprint.iacr.org/2017/627
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=78130828e9a140a9de4dafadbc844dbb64cb709a
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=8725c99ffa41778f382ca97233183bcd687bb0ce
- https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git%3Ba=commit%3Bh=e6a3dc9900433bbc8ad362a595a3837318c28fa9
- https://lists.gnupg.org/pipermail/gnupg-announce/2017q2/000408.html
- https://usn.ubuntu.com/3733-1/
- https://usn.ubuntu.com/3733-2/
- https://www.debian.org/security/2017/dsa-3901
- https://www.debian.org/security/2017/dsa-3960
Get alerted when CVE-2017-7526 or the next vulnerability affects your stack