What’s Vulnerable › Vulnerabilities
CVE-2017-7537
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-26 · updated 2026-06-17
- Weakness: CWE-592
Description
It was found that a mock CMC authentication plugin with a hardcoded secret was accidentally enabled by default in the pki-core package before 10.6.4. An attacker could potentially use this flaw to bypass the regular authentication process and trick the CA server into issuing certificates.
Affected products
- Dogtag PKI: before 10.6.4 — fixed in 10.6.4
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Dogtag PKI 10.6.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:2335
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7537
- https://github.com/dogtagpki/pki/commit/876d13c6d20e7e1235b9
- https://access.redhat.com/errata/RHSA-2017:2335
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7537
- https://github.com/dogtagpki/pki/commit/876d13c6d20e7e1235b9
Get alerted when CVE-2017-7537 or the next vulnerability affects your stack