What’s Vulnerable › Vulnerabilities
CVE-2017-7539
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-26 · updated 2026-06-17
- Weakness: CWE-617
Description
An assertion-failure flaw was found in Qemu before 2.10.1, in the Network Block Device (NBD) server's initial connection negotiation, where the I/O coroutine was undefined. This could crash the qemu-nbd server if a client sent unexpected data during connection negotiation. A remote user or process could use this flaw to crash the qemu-nbd server resulting in denial of service.
Affected products
- QEMU: before 2.10.1 — fixed in 2.10.1
- OpenStack: 6.0, 7.0, 8, 9, 10, 11
- RedHat Virtualization: 4.0, 3.0
How to fix
Upgrade to a fixed version: QEMU 2.10.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/07/21/4
- http://www.securityfocus.com/bid/99944
- https://access.redhat.com/errata/RHSA-2017:2628
- https://access.redhat.com/errata/RHSA-2017:3466
- https://access.redhat.com/errata/RHSA-2017:3470
- https://access.redhat.com/errata/RHSA-2017:3471
- https://access.redhat.com/errata/RHSA-2017:3472
- https://access.redhat.com/errata/RHSA-2017:3473
- https://access.redhat.com/errata/RHSA-2017:3474
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7539
- https://git.qemu.org/?p=qemu.git%3Ba=commitdiff%3Bh=2b0bbc4f8809c972bad134bc1a2570dbb01dea0b
- https://git.qemu.org/?p=qemu.git%3Ba=commitdiff%3Bh=ff82911cd3f69f028f2537825c9720ff78bc3f19
Get alerted when CVE-2017-7539 or the next vulnerability affects your stack