What’s Vulnerable › Vulnerabilities
CVE-2017-7550
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-21 · updated 2026-06-17
- Weakness: CWE-532
Description
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
Affected products
- Red Hat Ansible: from 2.3.0 before 2.3.3; from 2.4.0 before 2.4.1 — fixed in 2.3.3, 2.4.1
- RedHat Enterprise Linux Server: 7.0
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.3.3, 2.4.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2017:2966
- https://bugzilla.redhat.com/show_bug.cgi?id=1473645
- https://github.com/ansible/ansible/issues/30874
- https://access.redhat.com/errata/RHSA-2017:2966
- https://bugzilla.redhat.com/show_bug.cgi?id=1473645
- https://github.com/ansible/ansible/issues/30874
Get alerted when CVE-2017-7550 or the next vulnerability affects your stack