What’s Vulnerable › Vulnerabilities
CVE-2017-7562
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-26 · updated 2026-06-17
- Weakness: CWE-287
Description
An authentication bypass flaw was found in the way krb5's certauth interface before 1.16.1 handled the validation of client certificates. A remote attacker able to communicate with the KDC could potentially use this flaw to impersonate arbitrary principals under rare and erroneous circumstances.
Affected products
- MIT Kerberos 5: from 1.0 before 1.16.1 — fixed in 1.16.1
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.16.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/100511
- https://access.redhat.com/errata/RHSA-2018:0666
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7562
- https://github.com/krb5/krb5/pull/694
- https://github.com/krb5/krb5/pull/694/commits/1de6ca2f2eb1fdbab51f1549a25a6903aefcc196
- https://github.com/krb5/krb5/pull/694/commits/50fe4074f188c2d4da0c421e96553acea8378db2
- https://github.com/krb5/krb5/pull/694/commits/b7af544e50a4d8291524f590e20dd44430bf627d
- http://www.securityfocus.com/bid/100511
- https://access.redhat.com/errata/RHSA-2018:0666
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-7562
- https://github.com/krb5/krb5/pull/694
- https://github.com/krb5/krb5/pull/694/commits/1de6ca2f2eb1fdbab51f1549a25a6903aefcc196
Get alerted when CVE-2017-7562 or the next vulnerability affects your stack