What’s Vulnerable › Vulnerabilities
CVE-2017-7637
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-05 · updated 2026-06-17
- Weakness: CWE-78
Description
QNAP NAS application Proxy Server through version 1.2.0 allows remote attackers to run arbitrary OS commands against the system with root privileges.
Affected products
- QNAP Systems Inc. Proxy Server: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Proxy Server 1.3.0. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1041025
- https://www.qnap.com/en/security-advisory/nas-201806-01
- http://www.securitytracker.com/id/1041025
- https://www.qnap.com/en/security-advisory/nas-201806-01
Get alerted when CVE-2017-7637 or the next vulnerability affects your stack