What’s Vulnerable › Vulnerabilities
CVE-2017-7645
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-18 · updated 2026-06-17
- Weakness: CWE-20
Description
The NFSv2/NFSv3 server in the nfsd subsystem in the Linux kernel through 4.10.11 allows remote attackers to cause a denial of service (system crash) via a long RPC reply, related to net/sunrpc/svc.c, fs/nfsd/nfs3xdr.c, and fs/nfsd/nfsxdr.c.
Affected products
- Canonical Ubuntu Linux: 14.04
- Debian Linux: 8.0, 9.0
- Linux kernel: before 3.2.89; from 3.3 before 3.10.107; from 3.11 before 3.12.74; from 3.13 before 3.16.44; from 3.17 before 3.18.52; from 3.19 before 4.1.40 — fixed in 3.10.107, 3.12.74, 3.16.44, 3.18.52, 3.2.89, 4.1.40
How to fix
Upgrade to a fixed version: Linux kernel 3.10.107, 3.12.74, 3.16.44, 3.18.52. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3886
- http://www.securityfocus.com/bid/97950
- https://access.redhat.com/errata/RHSA-2017:1615
- https://access.redhat.com/errata/RHSA-2017:1616
- https://access.redhat.com/errata/RHSA-2017:1647
- https://access.redhat.com/errata/RHSA-2018:1319
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=e6838a29ecb484c97e4efef9429643b9851fba6e
- https://github.com/torvalds/linux/commit/e6838a29ecb484c97e4efef9429643b9851fba6e
- https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
- https://marc.info/?l=linux-nfs&m=149218228327497&w=2
- https://marc.info/?l=linux-nfs&m=149247516212924&w=2
- https://usn.ubuntu.com/3754-1/
Get alerted when CVE-2017-7645 or the next vulnerability affects your stack