What’s Vulnerable › Vulnerabilities
CVE-2017-7679
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 39.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-06-20 · updated 2026-06-17
- Weakness: CWE-126
Description
In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, mod_mime can read one byte past the end of a buffer when sending a malicious Content-Type response header.
Affected products
- Apache HTTP Server: from 2.2.0 before 2.2.33; from 2.4.0 before 2.4.26 — fixed in 2.2.33, 2.4.26
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.2.33, 2.4.26. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3896
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://www.securityfocus.com/bid/99170
- http://www.securitytracker.com/id/1038711
- https://access.redhat.com/errata/RHSA-2017:2478
- https://access.redhat.com/errata/RHSA-2017:2479
- https://access.redhat.com/errata/RHSA-2017:2483
- https://access.redhat.com/errata/RHSA-2017:3193
- https://access.redhat.com/errata/RHSA-2017:3194
- https://access.redhat.com/errata/RHSA-2017:3195
- https://access.redhat.com/errata/RHSA-2017:3475
- https://access.redhat.com/errata/RHSA-2017:3476
Get alerted when CVE-2017-7679 or the next vulnerability affects your stack