What’s Vulnerable › Vulnerabilities
CVE-2017-7690
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-04-14 · updated 2026-06-17
- Weakness: CWE-78
Description
Proxifier for Mac before 2.19.2, when first run, allows local users to gain privileges by replacing the KLoader binary with a Trojan horse program.
Affected products
- Proxifier: before 2.19.2 — fixed in 2.19.2
How to fix
Upgrade to a fixed version: Proxifier 2.19.2. Check the vendor advisory for mitigations.
References
- https://m4.rkw.io/blog/cve20177690-local-root-privesc-in-proxifier-for-mac-219.html
- https://www.exploit-db.com/exploits/43225/
- https://m4.rkw.io/blog/cve20177690-local-root-privesc-in-proxifier-for-mac-219.html
- https://www.exploit-db.com/exploits/43225/
Get alerted when CVE-2017-7690 or the next vulnerability affects your stack