What’s Vulnerable › Vulnerabilities
CVE-2017-7787
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-200
Description
Same-origin policy protections can be bypassed on pages with embedded iframes during page reloads, allowing the iframes to access content on the top level page, leading to information disclosure. This vulnerability affects Thunderbird < 52.3, Firefox ESR < 52.3, and Firefox < 55.
Affected products
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 55.0 — fixed in 55.0
- Mozilla Firefox ESR: before 52.3 — fixed in 52.3
- Mozilla Thunderbird: before 52.3 — fixed in 52.3
- Red Hat Enterprise Linux: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Desktop: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Server: 5.0, 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 5.0, 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 55.0; Mozilla Firefox ESR 52.3; Mozilla Thunderbird 52.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/100234
- http://www.securitytracker.com/id/1039124
- https://access.redhat.com/errata/RHSA-2017:2456
- https://access.redhat.com/errata/RHSA-2017:2534
- https://bugzilla.mozilla.org/show_bug.cgi?id=1322896
- https://security.gentoo.org/glsa/201803-14
- https://www.debian.org/security/2017/dsa-3928
- https://www.debian.org/security/2017/dsa-3968
- https://www.mozilla.org/security/advisories/mfsa2017-18/
- https://www.mozilla.org/security/advisories/mfsa2017-19/
- https://www.mozilla.org/security/advisories/mfsa2017-20/
- http://www.securityfocus.com/bid/100234
Get alerted when CVE-2017-7787 or the next vulnerability affects your stack