What’s Vulnerable › Vulnerabilities
CVE-2017-7818
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability can occur when manipulating arrays of Accessible Rich Internet Applications (ARIA) elements within containers through the DOM. This results in a potentially exploitable crash. This vulnerability affects Firefox < 56, Firefox ESR < 52.4, and Thunderbird < 52.4.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- Mozilla Firefox: before 52.4.0; before 56.0 — fixed in 52.4.0, 56.0
- Mozilla Thunderbird: before 52.4.0 — fixed in 52.4.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4
- RedHat Enterprise Linux Server Eus: 7.2, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.4.0, 56.0; Mozilla Thunderbird 52.4.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/101055
- http://www.securitytracker.com/id/1039465
- https://access.redhat.com/errata/RHSA-2017:2831
- https://access.redhat.com/errata/RHSA-2017:2885
- https://bugzilla.mozilla.org/show_bug.cgi?id=1363723
- https://lists.debian.org/debian-lts-announce/2017/11/msg00000.html
- https://security.gentoo.org/glsa/201803-14
- https://www.debian.org/security/2017/dsa-3987
- https://www.debian.org/security/2017/dsa-4014
- https://www.mozilla.org/security/advisories/mfsa2017-21/
- https://www.mozilla.org/security/advisories/mfsa2017-22/
- https://www.mozilla.org/security/advisories/mfsa2017-23/
Get alerted when CVE-2017-7818 or the next vulnerability affects your stack