What’s Vulnerable › Vulnerabilities

CVE-2017-7889

Description

The mm subsystem in the Linux kernel through 3.2 does not properly enforce the CONFIG_STRICT_DEVMEM protection mechanism, which allows local users to read or write to kernel memory locations in the first megabyte (and bypass slab-allocation access restrictions) via an application that opens the /dev/mem file, related to arch/x86/mm/init.c and drivers/char/mem.c.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.107, 3.12.74, 3.16.46, 3.18.50. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7889 or the next vulnerability affects your stack