What’s Vulnerable › Vulnerabilities

CVE-2017-7895

Description

The NFSv2 and NFSv3 server implementations in the Linux kernel through 4.10.13 lack certain checks for the end of a buffer, which allows remote attackers to trigger pointer-arithmetic errors or possibly have unspecified other impact via crafted requests, related to fs/nfsd/nfs3xdr.c and fs/nfsd/nfsxdr.c.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.16.44, 3.2.89, 4.1.40, 4.10.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7895 or the next vulnerability affects your stack