What’s Vulnerable › Vulnerabilities

CVE-2017-7981

Description

Tuleap before 9.7 allows command injection via the PhpWiki 1.3.10 SyntaxHighlighter plugin. This occurs in the Project Wiki component because the proc_open PHP function is used within PhpWiki before 1.5.5 with a syntax value in its first argument, and an authenticated Tuleap user can control this value, even with shell metacharacters, as demonstrated by a '<?plugin SyntaxHighlighter syntax="c;id"' line to execute the id command.

Affected products

How to fix

Upgrade to a fixed version: Enalean tuleap 9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-7981 or the next vulnerability affects your stack