What’s Vulnerable › Vulnerabilities
CVE-2017-7998
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Gespage before 7.4.9 allow remote attackers to inject arbitrary web script or HTML via the (1) printer name when adding a printer in the admin panel or (2) username parameter to webapp/users/user_reg.jsp.
Affected products
- Gespage: before 7.4.9 — fixed in 7.4.9
How to fix
Upgrade to a fixed version: Gespage 7.4.9. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2018/Jan/13
- https://sysdream.com/news/lab/2018-01-02-cve-2017-7998-gespage-stored-cross-site-scripting-xss-vulnerability/
- http://seclists.org/fulldisclosure/2018/Jan/13
- https://sysdream.com/news/lab/2018-01-02-cve-2017-7998-gespage-stored-cross-site-scripting-xss-vulnerability/
Get alerted when CVE-2017-7998 or the next vulnerability affects your stack