What’s Vulnerable › Vulnerabilities
CVE-2017-8023: EMC Networker Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-01 · updated 2026-06-17
- Weakness: CWE-287
Description
EMC NetWorker may potentially be vulnerable to an unauthenticated remote code execution vulnerability in the Networker Client execution service (nsrexecd) when oldauth authentication method is used. An unauthenticated remote attacker could send arbitrary commands via RPC service to be executed on the host system with the privileges of the nsrexecd service, which runs with administrative privileges.
Affected products
- Dell NetWorker: from 8.2.0.0 before 8.2.4.11; from 9.0.0.0 through 9.0.1.9; from 9.1.0.0 before 9.1.1.5; from 9.2.0.0 before 9.2.1.0 — fixed in 8.2.4.11, 9.1.1.5, 9.2.1.0
How to fix
Upgrade to a fixed version: Dell NetWorker 8.2.4.11, 9.1.1.5, 9.2.1.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107712
- https://seclists.org/fulldisclosure/2019/Mar/50
- http://www.securityfocus.com/bid/107712
- https://seclists.org/fulldisclosure/2019/Mar/50
Get alerted when CVE-2017-8023 or the next vulnerability affects your stack