What’s Vulnerable › Vulnerabilities
CVE-2017-8033
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-25 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in the Cloud Controller API in Cloud Foundry Foundation CAPI-release versions prior to v1.35.0 and cf-release versions prior to v268. A filesystem traversal vulnerability exists in the Cloud Controller that allows a space developer to escalate privileges by pushing a specially crafted application that can write arbitrary files to the Cloud Controller VM.
Affected products
- Cloud Foundry CAPI: before 1.35.0 — fixed in 1.35.0
- Cloud Foundry Cloud Controller cf-release versions prior to v255: before 268 — fixed in 268
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.35.0; Cloud Foundry Cloud Controller cf-release versions prior to v255 268. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-8033 or the next vulnerability affects your stack